Cannot install on Mint 13

*nix specific usage questions

Cannot install on Mint 13

Postby Doranwen » Thu Jul 30, 2015 4:55 am

I'm running Mint 13 Mate (it's an LTS release) and have Retroshare v0.5 running nicely on it. Just went to add a friend the other day and it took till they kept having errors importing my cert for me to go to the site--and even THEN it took a little while to spot the "incompatible with v0.5!" bit about the new release. (So as an aside, perhaps that could be made really visible and obvious on the front page so even newbies to RS can go "oh, it says it's incompatible with this old version, is yours that version?")

Aha, I figured, just need to install the new version and we're all set. So I went and updated my repos and went to install . . . and got this message:

The following packages have unmet dependencies:
retroshare06 : Depends: libsqlcipher0 (>= 1.1.9) but it is not installable
E: Unable to correct problems, you have held broken packages.

Which sounds to me like it requires a library that's not available on this version of Mint, probably due to age? Considering that Mint 13 is still under support (I believe it parallels Ubuntu LTS releases?) I was hoping that I wouldn't have to upgrade early (a mammoth undertaking, and one I won't have time for for several months at least) in order to run the new version of RS. (I did a search in my package manager, and that library did not appear at all, any version.)

If anyone has any suggestions besides "just upgrade!" I'd love to hear them. (I'm a teacher about to start teaching some new classes, so I'm going to be swamped and upgrading/installing new versions will take more time than I can spare any time soon.) The new features have me very excited--I'm just hoping I don't have to wait till I can upgrade to start using them.
Doranwen
 
Posts: 21
Joined: Fri Mar 07, 2014 10:29 am

Re: Cannot install on Mint 13

Postby heini » Thu Jul 30, 2015 3:56 pm

Hi,

Linux Mint 13 is based on Ubuntu Precise, right? There actually IS a 0.6 package for Precise in the PPA: https://launchpad.net/~csoler-users/+ar ... retroshare.

HTH...

Dirk
heini
 
Posts: 59
Joined: Sun Feb 02, 2014 8:37 am

Re: Cannot install on Mint 13

Postby Doranwen » Fri Jul 31, 2015 4:58 am

Yeah, that's the one I tried to install (I used the terminal for it, so typed "sudo apt-get install retroshare06" as instructed), and got the error message I posted about above. It apparently depends on a library that is not in my repositories anywhere. :? (I checked Package Manager just to be sure--that library does not appear at all, not even an older version of it.)

So I guess it's not a problem with needing to upgrade in that sense, but clearly there's an issue with the libraries--I don't know if it's just a Mint vs. Ubuntu thing (which is usually not an issue going this way!) or whether there's some library that wasn't taken into account, or what?
Doranwen
 
Posts: 21
Joined: Fri Mar 07, 2014 10:29 am

Re: Cannot install on Mint 13

Postby heini » Sun Aug 02, 2015 8:25 am

Ah, I see. The problem is that Precise, as well as Debian Wheezy and Jessie, doesn't provide packages for libsqlcipher. I've already fixed that for Debian Wheezy builds, but Ubuntu Precise and Debian Jessie need to follow.

However, in the meantime you could just download the source package of libsqlcipher from a later Ubuntu version and compile it locally on your system.

HTH...

Dirk
heini
 
Posts: 59
Joined: Sun Feb 02, 2014 8:37 am

Re: Cannot install on Mint 13

Postby Doranwen » Mon Aug 03, 2015 3:23 am

Ahh, that explains it. I'm afraid compiling packages is beyond my knowledge/comfort level for now, alas. Hopefully that'll get resolved soon.
Doranwen
 
Posts: 21
Joined: Fri Mar 07, 2014 10:29 am

Re: Cannot install on Mint 13

Postby heini » Mon Aug 03, 2015 4:26 pm

Hi,

just learned today that there are sqlcipher packages available in the guardianproject ppa.

HTH...

Dirk
heini
 
Posts: 59
Joined: Sun Feb 02, 2014 8:37 am

Re: Cannot install on Mint 13

Postby Doranwen » Thu Aug 06, 2015 5:04 am

Hmm, I see that it's only a development version--has anyone else here tried it? Would like to hear someone else's experience--if they had bugs with it or if it seemed to go smoothly, etc.--before I try installing it myself, if possible.

Thanks for spotting that--I had missed it.
Doranwen
 
Posts: 21
Joined: Fri Mar 07, 2014 10:29 am

Re: Cannot install on Mint 13

Postby heini » Sat Aug 08, 2015 7:03 am

Doranwen wrote:Hmm, I see that it's only a development version


How do you come to this conclusion? And no, it's not, see package details.

Bye...

Dirk
heini
 
Posts: 59
Joined: Sun Feb 02, 2014 8:37 am

Re: Cannot install on Mint 13

Postby Doranwen » Mon Aug 10, 2015 7:23 am

heini wrote:How do you come to this conclusion?


Misread something between the installation guide and the page, apparently. *headdesk* Sorry! Must've been tired at the time. It's been a hectic week.

Was able to install it fine this time. Thanks so much for the help! :)
Doranwen
 
Posts: 21
Joined: Fri Mar 07, 2014 10:29 am


Return to RetroShare for Linux and friends

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron