cant install retroshare in kali linux

*nix specific usage questions

cant install retroshare in kali linux

Postby rikino » Mon Feb 09, 2015 7:15 am

hello all i want to install retroshare in my kali linux but i got this problems i download the programm from the oficial page here

http://sourceforge.net/projects/retrosh ... re/0.5.5c/

and i donload the latest version , the file is .deb


i write in terminal sudo sudo dpkg -i RetroShare_0.5.4.5587_debian_i386.deb to install the deb file and it write me the message :


(Reading database ... 317456 files and directories currently installed.)
Preparing to unpack RetroShare_0.5.4.5587_debian_i386.deb ...
Unpacking retroshare (0.5.4.5587) over (0.5.4.5587) ...
dpkg: dependency problems prevent configuration of retroshare:
retroshare depends on libqt4-core; however:
Package libqt4-core is not installed.
retroshare depends on libqt4-gui; however:
Package libqt4-gui is not installed.
retroshare depends on libupnp3; however:
Package libupnp3 is not installed.
retroshare depends on libssl0.9.8; however:
Package libssl0.9.8 is not installed.

dpkg: error processing package retroshare (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.20-0.1) ...
Processing triggers for gnome-menus (3.4.2-5) ...
Errors were encountered while processing:
retroshare


and now i am stuck and i wonder : do i have to install these libqt4-core , libqt4-gui , libupnp3 and libssl0.9.8 ? if i need to install them what i write in terminal to install them ? :)
rikino
 
Posts: 7
Joined: Mon Feb 09, 2015 6:50 am

Re: cant install retroshare in kali linux

Postby ghibli » Mon Feb 09, 2015 11:01 pm

Kali seems to be debian, so you just need to:
sudo apt-get install libqt4-core
etc...
ghibli
 
Posts: 25
Joined: Sun Feb 01, 2015 1:44 pm

Re: cant install retroshare in kali linux

Postby rikino » Tue Feb 10, 2015 6:49 am

thanks i did the command sudo apt-get install libqt4-core
and terminal wrote to me


Reading package lists... Done
Building dependency tree
Reading state information... Done
libqt4-core is already the newest version.
libqt4-core set to manually installed.
The following package was automatically installed and is no longer required:
libqt4-gui
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 1839 not upgraded.



then i write command to install the deb retroshare file and i get this response from the terminal :

dpkg: regarding libupnp3_1.6.6-5+squeeze1_i386.deb containing libupnp3:
libupnp6 conflicts with libupnp3
libupnp3 (version 1:1.6.6-5+squeeze1) is to be installed.

dpkg: error processing archive libupnp3_1.6.6-5+squeeze1_i386.deb (--install):
conflicting packages - not installing libupnp3
Errors were encountered while processing:
libupnp3_1.6.6-5+squeeze1_i386.deb


and in my head i am saying : oh no you bad libupnp6 stop conflict with libupnp3 :lol:


with leatle research in internet i found that people suggest to uninstall libupnp6 and install libupnp3 ( i will lose the vlc but i need to install retroshare more than vlc )


am i correct in what am i saying ?
rikino
 
Posts: 7
Joined: Mon Feb 09, 2015 6:50 am

Re: cant install retroshare in kali linux

Postby ghibli » Tue Feb 10, 2015 8:47 am

Seems your kali linux uses a outdated version of debian, here is some people that has problems with debian and retroshare with the same library....
https://bugs.debian.org/cgi-bin/bugrepo ... bug=659069

They say in newer versions of debian is fixed, I'm using ubuntu and works fine.

You have latest kali version? 1.1.0? maybe that one whould work...
ghibli
 
Posts: 25
Joined: Sun Feb 01, 2015 1:44 pm

Re: cant install retroshare in kali linux

Postby rikino » Wed Feb 11, 2015 2:24 pm

thank you very much i will post the answer when problem is solved :D
rikino
 
Posts: 7
Joined: Mon Feb 09, 2015 6:50 am

Re: cant install retroshare in kali linux

Postby heini » Sun Feb 15, 2015 3:57 pm

Small add: On Debian and derivatives, if packages are installed via dpkg, missing dependencies can be resolved afterwards by simply running
Code: Select all
apt-get -f install


Bye...

Dirk
heini
 
Posts: 59
Joined: Sun Feb 02, 2014 8:37 am

Re: cant install retroshare in kali linux

Postby cave » Mon Feb 16, 2015 1:54 pm

is your Kali linux built upon

Debian: Squeece - Wheezy or Jessie ?
cave
 
Posts: 109
Joined: Tue Nov 13, 2012 10:27 pm

Re: cant install retroshare in kali linux

Postby rikino » Sat Feb 21, 2015 9:06 am

i did apt-get -f install
and it give me

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1861 not upgraded.

also i dont know what version of debian i have i have kali linux and i dont know what version sorry :(


please help me :roll:
rikino
 
Posts: 7
Joined: Mon Feb 09, 2015 6:50 am

Re: cant install retroshare in kali linux

Postby heini » Sat Feb 21, 2015 10:45 am

rikino wrote:i did apt-get -f install
and it give me

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1861 not upgraded.


OK, then I'd say try to upgrade your system first:
Code: Select all
apt-get update
apt-get dist-upgrade


also i dont know what version of debian i have i have kali linux and i dont know what version sorry :(


Why Kali at all? It's a specialized distro for pentration testing. Do you do penetration testing?

HTH...

Dirk
heini
 
Posts: 59
Joined: Sun Feb 02, 2014 8:37 am

Re: cant install retroshare in kali linux

Postby rikino » Sun Feb 22, 2015 10:31 am

heini i use kali because i think its cool :P

also if i do the dist update my laptop will need format :D i had done it before 4-5 days and then something went wrong i didnt know what to write and then i need to reinstall kali :roll:

i will do just update and tell u what message i take :)
rikino
 
Posts: 7
Joined: Mon Feb 09, 2015 6:50 am

Next

Return to RetroShare for Linux and friends

Who is online

Users browsing this forum: No registered users and 1 guest

cron