CVS Compiling

Old SourceForge Discussion forum that is now archived. Please use one of the other forums.

CVS Compiling

Postby Thomas » Thu Sep 11, 2008 10:08 pm

Since some days CVS compiling is not possible, there are some files missing:

./ui_LibraryDialog.h:27:25: Fehler: qformlayout.h: No such file or directory
In file included from gui/LibraryDialog.h:30,
from gui/ApplicationWindow.cpp:56:

Possible someone can upload them ?

thx
Thomas
 

RE: CVS Compiling

Postby CsoL » Fri Sep 12, 2008 6:59 am

This is typically a problem due to a .ui which is compiled with uic-4.3 but was created (or last edited) using designer-4.4.

To correct this: open LibraryDialog.ui with designer-4.3, save it, and recompile.

I don't know for windows, but on Ubuntu Qt-4.4 (from backport-hardy) has a bug in file seleciton boxes which makes it painful to use. I strongly suggest to use Qt-4.3. I ran into this ui bug myself after changing versions.

CsoL
CsoL
 

RE: CVS Compiling

Postby greyfox126 » Sat Sep 13, 2008 2:06 pm

yeah i ran into the same thing, need to use qt 4.4. to compile. theres been an addition from a developer using 4.4 i think.
greyfox126
 

RE: CVS Compiling

Postby Thomas » Mon Sep 15, 2008 12:40 pm

QT4.4 is not native available on my System.

It no problem to get a backport, but I think no one should use
QT4.4 for developement. It is to new, so normaly ditributions have
not includet it yet (for me, Ubuntu hardy).

thomas
Thomas
 


Return to Developers Corner - Archive

Who is online

Users browsing this forum: No registered users and 1 guest

cron