Failure to Compile

Old SourceForge Discussion forum that is now archived. Please use one of the other forums.

Failure to Compile

Postby Phil C » Fri Oct 24, 2008 8:12 pm

I'm working on the retromessenger project and I've been trying to get the Qt RetroShare to compile so I have a base to go off for our Qt gui. When I compile I get the following error message;

~/QtRetroM/qt/trunk/libraries/retroshare/pqi/ undefined reference to `SSL_get_peer_pgp_certificate'
collect2: ld returned 1 exit status
make: *** [QtRetromessenger] Error 1

I have made sure that the openssl libs are installed and that the makefile points to these libs. I also tried having the makefile point to the source of these libs. Both fail. I'm really at a loss here. Is this a known bug with the retroshare library? Or is there something I'm missing here?

Any help on this would be greatly appreciated. I'll be working on it in the meantime and I'll let ya'll know if I solve it before someone replies.

Thanks in advance for the help
Phil C

RE: Failure to Compile

Postby Dr Bob » Fri Oct 24, 2008 10:19 pm

Hi - it sounds like you are linking to the wrong ssl libraries.
The standard openssl does not have this function...

do you have openssl-xpgp compiled?

what is the full compile line?
where is openssl-xpgp installed?

If you are up to the linker errors - then you are really close to compiling it all!

Dr Bob

RE: Failure to Compile

Postby Phil C » Fri Oct 24, 2008 11:46 pm

I do have openssl-xgpg compiled. It's installed to /usr/local/ssl/openssl/. I've tried linking both to that directory and to the openssl-xpgp source. Both have failed at the same point.
Phil C

RE: Failure to Compile

Postby stockpicker » Fri Oct 24, 2008 11:59 pm

Hi Dr Bob,

I guess almost everyone who compiled libretroshare faced this problem...

libssl and libcrypto are available on any linux system, and whenever patched (openssl-xpgp) libraries are not found in the "-L" path, compiler silently uses "normal" libssl. Very confusing.

I ended up renaming libssl.a and libcrypto.a to libssl-xpgp.a and libcrypto-xpgp.a to be sure I link to openssl-xpgp, not to the standard openssl.

Maybe we could add this trick (renaming openssl-xpgp libraries) to the build scripts ? I'm sure it could save us lots of confusion in future.

RE: Failure to Compile

Postby Phil C » Sat Oct 25, 2008 10:54 pm

I tried renaming the libs and linking to openssl-xpgp instead. It's still not working. I continue to get the same error message.
Phil C

Return to Developers Corner - Archive

Who is online

Users browsing this forum: No registered users and 1 guest