Low upload rate

Technical RetroShare discussions Forum

Low upload rate

Postby retr0 » Mon Mar 19, 2012 2:26 pm

Hi,

I'm testing retroshare with a friend. Problem is low upload rate ( about 25 kb/s ). Speedmeter says about 500-600 kb/s are possible, so how can i set the up rate of rs higher? Settings are already set to 9999 kb/s maximum, that didn't help. I also opened ports in firewall settings, but not in router settings (because it's difficult, is this really neccesary?). NAT and DHP are green, Connection is set on manual forwarded port and discovery to public. What do i have to do to to raise up rate?

Greetings, retr0
retr0
 
Posts: 2
Joined: Mon Mar 19, 2012 2:18 pm

Re: Low upload rate

Postby retr0 » Thu Mar 22, 2012 1:11 pm

Is there really no one knowing what to do? :|
retr0
 
Posts: 2
Joined: Mon Mar 19, 2012 2:18 pm

Re: Low upload rate

Postby apoapo » Thu Mar 22, 2012 2:56 pm

My RS is able to get full (up to 1000kbyte) upload. So the code should be okay mostly.

Are u sure that:

-Your uload is free (ok, i think u are ;) )

-The downloader's upload is free? (Jammed upload of downloader means no download speed for him)
-> RS is known to have a slight priorisation on the uploads over the downloads. Please be sure that no cache file transfers are running while you check the speed. When youre friend is uploading those cache files, RS will use full upload speed to get them out -> download decreases to nearly zero.

-Try disabling DHT in the options. (Private only would be the option to use instead) DHT traffic does not count into upload limits and is able to jam your upload without beeing shown in the GUI :(

Hope this helps

cheers
apoapo
 
Posts: 189
Joined: Sun Jan 10, 2010 12:55 pm


Return to Technical RetroShare discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron